How to Clear the TCS Elevate Wings 1 DCA Exam

How to Clear the TCS Elevate Wings 1 DCA Exam: The Elevates Wings 1 DCA program is a Direct Capability Assessment for TCS associates with 0–3 years of work experience. It evaluates fundamental knowledge in at least one digital technology like cloud, data science, machine learning, artificial intelligence, blockchain, etc.

Passing the DCA can increase your salary by 100%. To pass, you must excel in the Technical + Managerial + HR interview and the online test (aptitude, logical reasoning, verbal, coding).

The coding test has medium complexity. With practice, it is passable. Solving previous year's questions will help in the next TCS DCA coding test.

TCS DCA Coding Questions

Q1: Write a Python program to remove vowels a, e, i, o, u from a given string. Ignore consecutive vowels.

Example 1: Input: "hello world", Output: "hll wrld"

Example 2: Input: "automobile", Output: "tmobl"

Python Program:

 def removeVowels(str): vowels = ['a','e','i','o','u'] result = [char for char in str if char.lower() not in vowels] return ''.join(result) string = input("Enter string: ") print(removeVowels(string)) 

Q2: Write a Python program to find and display prime numbers from a given list of integers. Take number of integers and the integer list as input.

Example 1:

Input:

 5 2 5 7 9 11 

Output: 2 7 11

Example 2:

Input:

 4 1 4 9 16 

Output: No prime numbers

Python Program:

 num = int(input("Enter number of elements: ")) arr = list(map(int,input("\nEnter the numbers separated by space: ").strip().split()))[:num] print("Prime numbers are: ") for i in arr: if i > 1: for j in range(2, int(i/2)+1): if (i % j) == 0: break else: print(i) 

Parallel Columbus Problem

Problem Statement: Nobel laureate Erwin Schrödinger brought many Christopher Columbus from parallel universes into a grid of size n x m. He placed some people of America at (x,y) and you at (n,m). All Columbus start from (1,1). Those reaching America think it's India. Find how many different Columbus will reach you as India first.

Function: markgame(n, m, x, y)

Parameters:

  • n - number of rows in grid
  • m - number of columns in grid
  • x,y - coordinates of America people

Constraints:

  • 1 <= n,m <= 1000
  • 1 <= x <= n
  • 1 <= y <= m

Input Format:

First line contains n and m separated by space

Second line contains x and y separated by space

Sample Input 1:

 2 2 2 1 

Sample Output 1:

 1 

Explanation: Only path is (1,1) -> (2,1) -> (2,2). So answer is 1.

Python Program:

 def markgame(n, m, x, y): if x == 1 and y == 1: return 0 count = 0 for i in range(1, n+1): for j in range(1, m+1): if i == x and j == y: break if i == n and j == m: count+=1 return count n, m = map(int, input().split()) x, y = map(int, input().split()) print(markgame(n, m, x, y)) 

Key Preparation Tips

To stay ahead in the competition, practice previous year papers to improve speed and accuracy. Download papers, take mock tests and analyze where you need more effort.

Visit exam website for syllabus, results, answer keys, best books etc. Join Telegram groups and online communities to boost your preparation.

Exam Tips Benefits
Solve previous papers Increases speed and accuracy
Take mock tests Evaluates preparation level
Analyze weak areas Improves performance

Conclusion

With thorough preparation using previous papers, mock tests and online communities, it is possible to excel in the TCS Wings 1 DCA exam. Focus on coding practice and have conceptual clarity in your core technology area. All the best!

Frequently Asked Questions

Q1: How to prepare for TCS DCA coding questions?

A1: Practice coding questions from previous TCS DCA exams. Focus on data structures, algorithms and logical thinking.

Q2: What is the exam pattern for TCS DCA?

A2: It has an interview round (technical, managerial, HR) and an online test (aptitude, reasoning, verbal, coding).

Q3: How much salary hike is given on passing TCS DCA?

A3: Passing DCA can result in a salary hike of around 100% depending on the grade.

Q4: What are the eligibility criteria for TCS DCA?

A4: 0-3 years experience and fundamental knowledge of any digital technology like AI, ML, cloud etc.

Q5: What is the exam duration of TCS DCA?

A5: The online test is for 90 minutes. Interview rounds depend on the panel.

Q6: How can I register for TCS DCA?

A6: Registration is done internally in TCS. Eligible associates are informed about DCA by HR.

 

Sarkari Awaaz | Sarkari Job | Sarkari Result

Tags